ViewXY - large amounts of flickering

A forum dedicated to WinForms version of LightningChart Ultimate.

Moderator: Arction_LasseP

greggorob64
Posts: 183
Joined: Tue Mar 18, 2014 2:55 pm

ViewXY - large amounts of flickering

Post by greggorob64 » Tue Sep 06, 2016 4:20 pm

I'm the last couple months i've a had a few recurring issues:

1) I am having traces completely dissapear from view and then come back when I move my mouse
2) I am having a lot of flickering in the cursors 'cross points'. I have attached a gif below, this is just showing the cursor flickering.

You can see i have a whole bunch of logic in here. However, i dont think its always done this, it seems like a relatively recent thing (whatever release had the NaN region gaps).

I'm not sure where to start to diagnose and fix this issue. Any thoughts?

Image

User avatar
ArctionPasi
Posts: 1366
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland

Re: ViewXY - large amounts of flickering

Post by ArctionPasi » Tue Sep 06, 2016 8:05 pm

7.1 version has DX11 renderer as default. Please set chart.RenderOptions.DeviceType = AutoPreferD9.

Does the flickering go away?

If there's a problem in DX11 renderer, we definitely want to fix it, please just teach us how to reproduce the issue.
LightningChart Support Team, PT

greggorob64
Posts: 183
Joined: Tue Mar 18, 2014 2:55 pm

Re: ViewXY - large amounts of flickering

Post by greggorob64 » Wed Sep 07, 2016 1:29 pm

Switching to directx 9 makes the flickering go away. I'll start the arduous process of making an example for ya :P

greggorob64
Posts: 183
Joined: Tue Mar 18, 2014 2:55 pm

Re: ViewXY - large amounts of flickering

Post by greggorob64 » Wed Sep 07, 2016 2:47 pm

I emailed support@arction.com with the reproduction sample

greggorob64
Posts: 183
Joined: Tue Mar 18, 2014 2:55 pm

Re: ViewXY - large amounts of flickering

Post by greggorob64 » Thu Sep 22, 2016 12:47 pm

This issue was fixed in 7.1.3.3