Rectangle AnnotationStyle Seems Invisible with Hardware 9

A forum dedicated to WinForms version of LightningChart Ultimate.

Moderator: Arction_LasseP

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

Rectangle AnnotationStyle Seems Invisible with Hardware 9

Post by plotter » Mon May 01, 2017 4:33 am

Hello Arction Support,

I need to use Hardware 9 for rendering and am finding that the AnnotationStyle.Rectangle displays with a black frame and no content for me.
I think RectangleArrow does it also. All other shapes seem Ok.

I experience this behavior with the ExampleAnnotationsXY and the ExampleAnnotationsTable

Switching the device from Hardware 11 to Hardware 9 causes all rectangular AnnotationXY objects to become transparent, back to 11, and they are visible again.
(the other shapes are unaffacted)

Could you please take a look at this?

Thanks,

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by plotter » Mon May 01, 2017 8:54 pm

I have found a workaround that solves my problem.

I have selected AnnotationStyle.RoundedRectangle, then set .CornerRoundRadius = 0;

Thanks.

ArctionKestutis
Posts: 386
Joined: Mon Mar 14, 2016 9:22 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by ArctionKestutis » Tue May 02, 2017 7:28 am

Hello,

If you are setting Annotation.Fill.Style = None, don't forget about Shadow (Annotation.Shadow.Visible = false).

If you see problems with Hardware 9 on ExampleAnnotationsXY and ExampleAnnotationsTable, it is more worrying. Then we would like to know more details how to reproduce problem. Could you share details about OS, GPU and graphic driver version (DxDiag output is perfect for that). And we also would need to know the LightningChart version (4 digits please) and edition (WinForms, WPF, bindible).

All the best,
Kestutis

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by plotter » Fri May 05, 2017 3:35 am

Hello,
I have tested on different hardware and found out the behavior is only on VMware SVGA 3D guest virtual adapter. I tested it on 2 different hardware platforms with different video cards. Both had no artifacts running on the host hardware, but did have the transparency artifacts when running in a vm.
(Latest video drivers, 3D acceleration enabled, 2GB video ram, w10 and s2012R2, LC 8.02.4001)

The examples present the artifacts when rendering any rectangular annotationXY. Switching the style to rounded rectangle seems to help.
Besides the transparent backgrounds on rectangle AnnotationXY objects, there is a lot of flicker during mouse movement as well...

It WOULD be great if you could get DirectX11 working on VMware without the flicker...
The DirectX9 Driver does not seem to shade as smoothly the 11 driver...

I suspect you probably have quite a few other customers running your product in a vmware environment...

You can probably download a 30 day trial for free to use to resolve the issue...
Thanks Again for your Superb Product Support...

ArctionKestutis
Posts: 386
Joined: Mon Mar 14, 2016 9:22 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by ArctionKestutis » Fri May 05, 2017 1:45 pm

Hello,

Thank you for the details. I was able to replicate Annotation fill problem on VMware Workstation with LightningChart running in Hardware9 mode. Both Hardware and Software 11 engines render Annotations correctly. We will look at the RE9 issue as soon as possible.
However, I don't see flickering, at least during mouse movement. What kind of flickering you see with device type Hardware11? Is it occasional gridline intensity change during panning in the same Annotation example?

All the best.

ArctionTero
Posts: 42
Joined: Thu Mar 28, 2013 9:20 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by ArctionTero » Wed Sep 13, 2017 9:06 am

Hello plotter,

Is this still an issue or are satisfied with the workaround?
LightningChart Support Team, TK

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

Re: Rectangle AnnotationStyle Seems Invisible with Hardware

Post by plotter » Mon Sep 18, 2017 7:24 pm

Hi,
I still see unusual behavior with the rectangle fill with DX11 and DX9.
I still get flicker when running in a vmWare environment using DX11, so I am forced to use DX9 there. The annotation fill gradient background seems to work differently between the different versions.
I have overcome the rectangle annotation transparency by using a rounded rectangle with minimal radius.
The 3D charts within charts sample for instance shows the background map bitmap as black with DX9, but does render it correctly with DX11.
I guess I have learned to work around the current limitations and added extra code where necessary to achieve a consistent result.
I do have some more critical questions which I will ask in new threads.
Thanks,
Heather