How do I prevent y scaling from using exponents?

A forum dedicated to WinForms version of LightningChart Ultimate.

Moderator: Arction_LasseP

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

How do I prevent y scaling from using exponents?

Post by plotter » Mon Sep 18, 2017 8:06 pm

Hi,
I have a number of segments each with a number of Y axis's and point line series.
When I try to scale data what doesn't have more than 1 value within the x range, the Y scaling switches to exponent display, with some massive value as the high and low extremes.
Is there an intrinsic way to simply prevent scaling/fitting to occur when there is only 1 data point within the range?
Or when the scaling/fitting is acting on the visible range, when there are no data points in that range, the same thing happens...

Ideally, when there is less than 2 data points, I'd like to skip scaling/fitting...

Also when I am zooming in on data, and then running autofit on Y, If there is not any points within the visible range, there is no point line visible,
How do I auto fit Y (on a zoomed in x range) with no data points specifically within the visible x range, and use the adjacent data point values (outside of the visble range) to display the line through the visible range? (Is this possible?)

(When there is more than 1 data point in the range, everything works just fine.)

User avatar
ArctionNikolai
Posts: 38
Joined: Fri Feb 05, 2016 11:37 am
Location: Finland

Re: How do I prevent y scaling from using exponents?

Post by ArctionNikolai » Wed Sep 20, 2017 9:36 am

Hello,
When there is more than 1 data point in the range, everything works just fine.
If you have only 1 data point, the fitting will show the data in the middle of a chart in an appropriate coordinate. If you have several series with 1 data point each, after fitting they will be in the middle of the chart in x-direction and y-axis will be scaled between highest and lowest y-coordinate of data-point.
Ideally, when there are less than 2 data points, I'd like to skip scaling/fitting...
Each line-series has a property with a name series.IncludeInAutoFit with a type boolean. You can set it to False, and this specific series will not be affected by the view.ZoomToFit() or view.ZoomPanOptions.AutoYFit. You can enable and disable this property whenever you need.
Also when I am zooming in on data, and then running autofit on Y, If there are not any points within the visible range, there is no point line visible,
This functionality does not take into account all the data outside the visible x-range, it fits the data between the maximal and minimal y-coordinates only within the visible x-range.
How do I auto fit Y (on a zoomed in x range) with no data points specifically within the visible x range, and use the adjacent data point values (outside of the visible range) to display the line through the visible range? (Is this possible?)
It is better to use a normal ZoomToFit() method for that.

Best regards,
Nikolai Arsenov
Software developer
Arction Ltd
Microkatu 1, 70210 Kuopio, Finland

plotter
Posts: 41
Joined: Thu Apr 06, 2017 2:29 am

Re: How do I prevent y scaling from using exponents?

Post by plotter » Wed Sep 20, 2017 11:15 am

Thank You,
Heather