Icons/Checkboxes Not Appearing in Legend

A forum dedicated to WinForms version of LightningChart Ultimate.

Moderator: Arction_LasseP

sph
Posts: 3
Joined: Tue Mar 27, 2018 1:40 am

Icons/Checkboxes Not Appearing in Legend

Post by sph » Tue Mar 27, 2018 1:50 am

I am currently not seeing any icons or checkboxes appear in my Legend when trying to make a Bar chart. I have essentially replicated the example code given in ExampleBarsSimple.cs, and have set both ShowIcons and ShowCheckboxes to true.
Are there any other properties or settings that could cause the Icons/Checkboxes to not appear in the legend?

ArctionKestutis
Posts: 383
Joined: Mon Mar 14, 2016 9:22 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by ArctionKestutis » Tue Mar 27, 2018 1:52 pm

Hi,

I could only think about disabled Series.ShowInLegendBox, but then you would not see series' title as well.
Subscribe to _chart.ChartError event to check that there is no warning or errors reported in event handler.
Subscribe to _Chart.AfterRendering event and check those mentioned properties - are those still set to values you assume.

Hope this helps.
All the best.

sph
Posts: 3
Joined: Tue Mar 27, 2018 1:40 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by sph » Wed Mar 28, 2018 7:49 pm

Hello,

Thanks for the event recommendations; using these I was able to confirm that the ShowIcons and ShowCheckboxes properties were set to true, and that LightningChart was not reporting any errors. I've attached a screenshot of what the chart looks like, with the icons and checkboxes still not appearing for some reason.
If you have any additional ideas, I'd be very grateful. I'm able to see the checkboxes and icons in the example chart shown using the WinForms v.8.2 Demo executable, so it is very puzzling why the same code does not behave the same way in my project..

Thanks!
Attachments
LightningChartNoIconsOrCheckboxes.PNG
LightningChartNoIconsOrCheckboxes.PNG (40.73 KiB) Viewed 7367 times

ArctionKestutis
Posts: 383
Joined: Mon Mar 14, 2016 9:22 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by ArctionKestutis » Thu Mar 29, 2018 11:20 am

Hello,

What would be "essentially replicated the example code"? If you dropping LightningChart component from Visual Studio Toolbox it maybe significant difference. We recommend using complete Chart creation in the code, due to occasional (de)serialization problem :oops:
If this is not the reason, when please send your test project to Support email account or upload here. It may be some combination of other setting we not aware yet.

All the best.

sph
Posts: 3
Joined: Tue Mar 27, 2018 1:40 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by sph » Thu Mar 29, 2018 5:35 pm

Hi,

Thank you for recommending the complete Chart creation in the code, that has fixed it! The checkboxes and icons are now appearing in the legend.

Many thanks!

Geoff_S
Posts: 1
Joined: Tue Jul 03, 2018 12:56 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by Geoff_S » Tue Jul 03, 2018 2:52 am

I had exactly the same problem, and the exact same solution worked for me. As an aside - I did find it convenient to drop the LightningChart component onto a form, since it was easy to then browse the available properties and settings without reading a manual.

ArctionKestutis
Posts: 383
Joined: Mon Mar 14, 2016 9:22 am

Re: Icons/Checkboxes Not Appearing in Legend

Post by ArctionKestutis » Mon Jul 09, 2018 6:09 am

Using the properties grid from our Demo App ('Properties' button at the top) should be excellent alternative for the Designer. Just open any example, select property grid and modify almost any property to your liking. The result are seen instantly.