Slow rendering when debugger is attached

A forum dedicated to WPF version of LightningChart Ultimate.

Moderator: Arction_LasseP

SupportArchives
Posts: 16
Joined: Tue Mar 26, 2013 11:01 pm

Slow rendering when debugger is attached

Post by SupportArchives » Thu Apr 25, 2013 1:10 pm

I've noticed that when running the chart application with VS debugger, the rendering efficiency is only fraction of when I run it from Windows Explorer. Why and can I do something to run it at full speed from Visual Studio? :?:

User avatar
ArctionPasi
Posts: 1366
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland

Re: Slow rendering when debugger is attached

Post by ArctionPasi » Thu Apr 25, 2013 1:14 pm

LightningChart Ultimate uses multithreading to divide the load into several CPU cores. VS debugger prevents real multi-threading and appears as highly reduced performance. :(

Run your app without attachment of debugger, by pressing Ctrl + F5, or select "Debug / Start Without Debugging" from the VS main menu.
LightningChart Support Team, PT

Salto
Posts: 27
Joined: Mon Jan 13, 2014 5:43 pm

Re: Slow rendering when debugger is attached

Post by Salto » Tue Jan 05, 2016 7:05 am

Hi. Is there a way to improve the performance when the debugger is attached? Currently it takes about 11s to initialize the chart control without any data... Any ideas?
Thanks in advance!

User avatar
ArctionPasi
Posts: 1366
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland

Re: Slow rendering when debugger is attached

Post by ArctionPasi » Tue Jan 05, 2016 8:12 am

Improvement is coming in v.7
LightningChart Support Team, PT